Citrix PVS rebalancing leaves target devices unresponsive with CheckPoint agent installed
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Article ID: CTX691734
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Updated On:
Description
Rebalancing PVS targets devices ends up with the target devices in an unresponsive frozen state.
The only method to recover target devices is to force restart the target devices on the hypervisor.
Customer validated all PVS servers are configured as PVS login servers.
Target devices fail to reconnect if manually disconnected and reconnected, or if the PVS server they are streaming from reboots.
PVS HA reconnect does not function for the customer for the specific vdisk.
Environment
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Resolution
The issue could not be reproduced with the CheckPoint Identity Agent uninstalled from the vdisk.
A solution advised was to use CheckPoint Identity Agent configuation below:
- Using latest version, installation of the CheckPoint agent contains two Multi User Host Agent versions - MUH v1 or MUH v2 , choose option Multi User Host Agent v2

- Configure registry value
Location: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\CheckPoint\IA
Name :"IsMUH"
Type: DWORD
Value: 00000002

Problem Cause
Customer found the issue source was the presence of CheckPoint Identity Agent installed in the vdisk.
The issue could not be reproduced with the CheckPoint Identity Agent uninstalled.
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