Error "Invalid Client ID/Secret key" throws while configuring Probe Agent for Cloud Monitor

Error "Invalid Client ID/Secret key" throws while configuring Probe Agent for Cloud Monitor

book

Article ID: CTX677929

calendar_today

Updated On:

Description

While configuring Citrix Probe Agent for Cloud Monitor it throws error "Invalid Client ID/Secret key" although Client ID, Secret and Customer ID are correct.

Resolution

Check following URLs are accessible from the machine where Probe Agent is installed. If they are not accessible whitelist them in the Firewall/Proxy.

You can test it using PowerShell. For example

Test-NetConnection trust.citrixnetworkapi.net -Port 443

 

 

 

Complete list of URLs to be whitelisted are here.
https://fqdnallowlistsa.blob.core.windows.net/fqdnallowlist-commercial/allowlist.json

Recommendation is to whitelist wildcard URLs

https://*.citrixnetworkapi.net
https://*.citrixworkspacesapi.net
https://*.apps.cloud.com
https://*.cloud.com


Problem Cause

Required URLs are not whitelisted.