VDA registration failures after Cloud Connector rebooted for OS updates

VDA registration failures after Cloud Connector rebooted for OS updates

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Article ID: CTX676752

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Updated On:

Description

Virtual Delivery Agent (VDA) machines fail to register after a Cloud Connector on version 6.92.0/4.349.0 restarts following an OS update.

The event logs of the Cloud Connector will have the following events written prior to system restart and the registration failures:

Source: User32
EventID: 1074
Level : Information
Message: "The process C:\Windows\System32\shutdown.exe (<MACHINE-NAME>) has initiated the restart of computer <MACHINE-NAME> on behalf of user NT AUTHORITY\SYSTEM for the following reason: Application Installation (Planned)
Reason Code: 0x80040002
Shutdown Type: restart
Comment: Citrix Cloud restarted the machine to complete a maintenance operation on the Connector."


The event logs of the VDAs will have the following events written during registration failures:

Source: Citrix Desktop Service
Event ID: 1023
Level: Warning
Message: Broker Proxy received an error from cloud DDC.


Note: These messages may also be caused by other issues not related to this topic.

Resolution

To temporarily resolve the issue, restart the Remote Broker Provider Service on the affected Cloud Connector Server.

Citrix is actively deploying a permanent fix to all Cloud Connectors for this problem:

  • Connector Version: 6.92.0
  • Connector Components: 4.349.300

Once the update is scheduled for your Cloud Connector, you will receive a console notification stating "A Citrix Connector Update is scheduled to occur". For Resource Locations with a Maintenance Window defined, you can then perform an on-demand update to receive the new version before your scheduled maintenance window.

 

From here:  
- It will show you where to check the Connector versions under section [Compare Cloud Connector versions]:
- Under Citrix CaaS > Home > Resource Locations > Cloud Connectors ( "select the ..." and  "View Connector Data") > Connector Data
  
  - The Target version number is the latest version
  - The Current version is the version you are on

 

To know the Connection "Version State" - Either displays [Normal] or [Hotfix]

- This is not publicly available for users & you would need to contact Citrix Support or TAM to request this information for you.


Problem Cause

This issue is caused by a software bug in the Cloud Connector.

Issue/Introduction

Virtual Delivery Agent (VDA) machines fail to register after a Cloud Connector on version 6.92.0.X restarts following an OS update. To temporarily resolve the issue, restart the Remote Broker Provider Service on the affected Cloud Connector Server.

Additional Information

https://docs.citrix.com/en-us/citrix-cloud/citrix-cloud-resource-locations/connector-updates.html#update-notifications-and-on-demand-updates