Policy data may be lost when a CVAD site is upgraded from a previous version to 2402

Policy data may be lost when a CVAD site is upgraded from a previous version to 2402

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Article ID: CTX676686

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Updated On:

Description

Please note:
You can download the required file from the Citrix downloads website by visiting the following link: https://www.citrix.com/downloads/citrix-tools

 

It's recommended that this tool be run prior to the upgrade to validate Policy compatibility.

Pre-Upgrade Steps:

      • Version CVAD 2402 
        • Ensure that you have a recent backup of the three Citrix Databases (Site/Logging/Monitoring)
        • Run the attached Policy Validation Tool (GPOScanner)
          • Address any errors due to invalid policy settings (Instructions below)
          • Proceed with the upgrade. Additional Information on the Upgrade process and recommendations can be found here.

Post-Upgrade Steps:

      • Version CVAD 2402
      • Option A:
        • Recreate missing policies in Studio
      • Option B (If DB Backup Available):
        • Downgrade to the previous version from which the system was upgraded from
        • Restore the three Citrix Databases from backup
        • Run the attached Policy Validation Tool (GPOScanner)
          • Address any errors due to invalid policy settings (Instructions below)
          • Proceed with the upgrade. Additional Information on the Upgrade process and recommendations can be found here.

 

GPO Scanner Tool Instructions:

Please Note:  The tool can be run on the Desktop Delivery Controller (DDC) or any standalone machine that has the Citrix Policy exported blob.

 

  1. Download the GPO Scanner tool & extract it to your machine (GPOScanner.exe).

  2. Open the command prompt & browse to the tool location.

    • To execute the tool on the controller machine

      • Run the command: GpoScanner.exe.

    • To execute the tool on a standalone machine

      • Run the command: GpoScanner.exe “<Citrix GPO Blob path>

  3.  Review the tool output & take appropriate action to rectify the reported errors.

  4. Once corrective actions have been taken, please re-run the tool to confirm the errors have been cleared.

 

Examples:

Tool executed on the controller:

Controller.png

 

Tool executed on a standalone machine:

Exe_Standalone_Machine.png

Tool reporting with no errors:

ReportingErrors.png

 

Environment

These software applications are provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the code be used to support of ultra-hazardous activities, including but not limited to life support or blasting activities.NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the code.

Issue/Introduction

Policy data may be lost when a CVAD site is upgraded from an older version to 2402.

Additional Information

Please note:
You can download the required file from the Citrix downloads website by visiting the following link: https://www.citrix.com/downloads/citrix-tools

Problem Cause:

  • Additional setting validations were added as part of an update to Citrix DaaS, CVAD 2311, and CVAD 2402 releases.

  • Now, there is a restriction to keep the policy name length within 64 characters.
  • Settings from previous releases that have invalid entries will fail to pass validation on the data. This causes the policy data processing to abort early. Policies that were already processed are intact, but any policies after the error are removed from the site.

    • Invalid data may be present in the following:

  • WebSockets trusted origin server list.

  • Rendezvous proxy configuration.

  • List of applications excluded from failure monitoring.

  • Browser content redirection proxy configuration.

  • Universal printing optimization defaults.

  • Allowed URLs to be redirected to VDA.

  • Allowed URLs to be redirected to Client.

  • Client USB device optimization rules

  • User layer repository path

  • Loss-tolerant mode thresholds

  • Printer Assignments

  • Session Printers

  • Examples of how invalid data may persist in a policy setting:

1. Virtual channel allow list may have the following invalid input:

ABCD,C:\Program.exe

A1

B2

Expected input:

Each line should be in the format: VCNAME,ProgramExecutable. 

Hence, here lines A1 and B2 are not allowed with the validation.

2.  In the below example, Allow: has been entered as part of the value, which makes it invalid.

EditSetting_Latest.png