PVS | StreamService cannot access vDisks after reboot

PVS | StreamService cannot access vDisks after reboot

book

Article ID: CTX666283

calendar_today

Updated On:

Description

Intermittent problems with the StreamService of the PVS servers. Infrequently, when the PVS server boots, the StreamService is unable to access the vDisks. The event logs show the error message "Login failed (error code: 2) for device <device name>: Server <server IP>: vDisk file access permission denied".

Two short-term workarounds exist:

  • restart the StreamService
  • explicitly authorize the StreamService user to the disk on which the vDisks and .pvp files are located. 
    • this might not always be possible due to security policies

Resolution

Set Stream and Soap Service to delayed start: Extend the delay by modifying the below registry value: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\<service name>\

To increase the default delay of 120 seconds, add a new value:

  • Type: DWORD
  • Name: AutoStartDelay
  • Value: in milliseconds (decimal), e.g. 240000 for 240 seconds.

Problem Cause

Configuration: timing issue when setting an SPN immediately prior to service start which causes subsequent auth failures.

Issue/Introduction

Timing issues at startup can cause vDisk file access permission denied errors. To prevent this, set Stream and Soap Service to delayed start via registry keys.