Client drive not mapping after reconnection

Client drive not mapping after reconnection

book

Article ID: CTX633145

calendar_today

Updated On:

Description

Client drive mapped via CDM disappeared after reconnecting by session reliability.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Disable FastReconnect on the Virtual Delivery Agent via the Registry.
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Reconnect]
"FastReconnect"=dword:00000000


Problem Cause

When session reconnected by session reliability, the fast reconnect feature will function by default.
Client drive mapping did not work properly when fast reconnect taking place.