Citrix Director reports ICA Latency value as 0

Citrix Director reports ICA Latency value as 0

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Article ID: CTX616926

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Updated On:

Description

  • ICA Latency value shows as 0 while ICA RTT shows correctly in Citrix Director.
  • The issue is seen for ICA sessions coming via NetScaler.
  • The issue may be seen for CVAD version 2112 and above.
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  • Get-CimInstance -Namespace root\Citrix\EUEM -Class Citrix_euem PowerShell output shows NetworkLatency as 0 and Ctxsession-v output also shows HDX Latency value as 0.

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Environment

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Resolution

  • Creating the below registry key to disable Adaptive Scaling on the VDA side fixed the issue and the ICA Latency value started showing in Director.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\icawd
Name: AdaptiveScalingEnabled
Type: DWORD
Value: 0

  • This registry fix allows you to use the legacy NetScaler L7 latency measurement when the HDX Adaptive Scaling feature is disabled. The NetScaler L7 latency and VDA HDX Adaptive Scaling features can’t be enabled simultaneously.
Reference: This is documented under [CVADHELP-19781] in https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/2203-ltsr/whats-new/cumulative-update-1/fixed-issues.html
 

Problem Cause

This issue is caused by NetScaler L7 Latency and HDX Adapting Scaling features conflict.

Issue/Introduction

This article describes a known issue seen due to This issue is caused by NetScaler L7 Latency and HDX Adapting Scaling features conflict.