Citrix Director reports ICA Latency value as 0
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Article ID: CTX616926
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Updated On:
Description
- ICA Latency value shows as 0 while ICA RTT shows correctly in Citrix Director.
- The issue is seen for ICA sessions coming via NetScaler.
- The issue may be seen for CVAD version 2112 and above.
- Get-CimInstance -Namespace root\Citrix\EUEM -Class Citrix_euem PowerShell output shows NetworkLatency as 0 and Ctxsession-v output also shows HDX Latency value as 0.
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
- Creating the below registry key to disable Adaptive Scaling on the VDA side fixed the issue and the ICA Latency value started showing in Director.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\icawd
Name: AdaptiveScalingEnabled
Type: DWORD
Value: 0
Problem Cause
This issue is caused by NetScaler L7 Latency and HDX Adapting Scaling features conflict.
Issue/Introduction
This article describes a known issue seen due to This issue is caused by NetScaler L7 Latency and HDX Adapting Scaling features conflict.
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