Citrix Cloud Intermittent loss of connectivity to On-Prem AD

Citrix Cloud Intermittent loss of connectivity to On-Prem AD

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Article ID: CTX588031

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Description

When attempting to run MCS Process - Ran into issues contacting the On-Prem Active Directory 

## Citrix.CloudServices.ADAgent [EventID 10102] Errors:  Message=Unable to connect to the forest associated with domain "DOMAIN_NAME.local".

 

Resolution

Under Citrix DaaS > Identity & Access Management > Domains

- There were two Domain available under Identity & Access Management

- There were two Preferred Connector options [Forest Preferred Connector Type: Connector Appliance (Linux Box for SPA) & Connector (Citrix Cloud Windows Connector) ]

- Changing the Forest Preferred Connector Type: Connector Appliance -> Connector [ resolved the issue ]


Problem Cause

## Citrix.CloudServices.ADAgent [EventID 10102] Errors:  Message=Unable to connect to the forest associated with domain "root.local".

## As the Connector Appliance (is the Linux box, which had no open ports to your Domain Controllers)

## This was the set as the primary choice superseding other configuration for using other CCs

## As a result - it could not connect during Catalog creation process (nor during the Machine Account creation stage)