Citrix DaaS | Workspace expiration period forced Users to re-authenticate

Citrix DaaS | Workspace expiration period forced Users to re-authenticate

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Article ID: CTX588029

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Updated On:

Description

When the user logs in to workspace URL, they are unexpected behavior while using CWA.
- They will be prompted to keep themselves logged in due to a Inactive policy set.
- Once they select keep me logged in, the workspace page gets refreshed and they don't see any apps or desktops.
- Application\Desktop enumeration fails after clicking on keep me logged in.
- Need to completely sign out & sign back is to resolve

Resolution

Fix [CCPHELP-8709] | [WSHELP-383] part of ATH-18365 [Production:20240114-release [ATHREL-78] ]

[Cache TTL is set to 60 seconds]
- With the latest changes, this Cache token is retained [Containing the cached groups] & the enumeration does not require another re-authentication process to query for that user and their associated user groups & apps/desktops associated (as a result the refresh does not result in a clearing of the previously enumerated Apps/Desktops for the affected user).


Problem Cause

Workspace expiration period forced Users to re-authenticate