CVAD 2203- Services are failing intermittently after restart

CVAD 2203- Services are failing intermittently after restart

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Article ID: CTX587680

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Updated On:

Description

After a database outage, restarting Citrix processes on the controllers, as well as rebooting the entire controller, results in crash notifications in event viewer and odd behavior.

Resolution

Customer reported that after an upgrade to the latest version of ControlUp, these errors were no longer seen in the event log.

Problem Cause

On reboot, some of the services were being checked by ControlUp monitoring before they were completely up and available. This caused errors in the event log and CDF tracing, but afterwards, services were available and there was no production impact.