Studio will not open with error "A working 'Storefront' service could not be found"

Studio will not open with error "A working 'Storefront' service could not be found"

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Article ID: CTX587651

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Updated On:

Description

Storefront is installed on the DDC.

After successfully upgrading both Storefront servers to CVAD 2203 CU3, Studio fails to open with the following error.

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After clicking on "View Details" another error appears:  "A working 'Storefront' service could not be found"

 

Error Id: XDDS:E354580F

Exception:
DesktopStudio_ErrorId : UnknownError
ErrorCategory : NotSpecified
DesktopStudio_PowerShellHistory : LoaderScript
<Date> <Time>

Get-ConfigServiceStatus  -AdminAddress "localhost" -BearerToken ********
Get-ConfigServiceStatus  -AdminAddress "localhost" -BearerToken ********

Get-ConfigServiceStatus  -AdminAddress "DDC_FQDN" -BearerToken ********
Get-ConfigServiceStatus  -AdminAddress "DDC_FQDN" -BearerToken ********

Get-ConfigZone  -AdminAddress "localhost" -BearerToken ******** -MaxRecordCount 2147483647 -Property @("Uid","IsPrimary")

Get-ConfigRegisteredServiceInstance -AdminAddress "localhost" -BearerToken ******** -Filter {(((ServiceType -eq 'Config') -and (Version -eq 2)) -or ((ServiceType -eq 'Admin') -and (Version -eq 1)) -or ((ServiceType -eq 'Log') -and (Version -eq 1)) -or ((ServiceType -eq 'Acct') -and (Version -eq 2)) -or ((ServiceType -eq 'Hyp') -and (Version -eq 2)) -or ((ServiceType -eq 'AppLib') -and (Version -eq 1)) -or ((ServiceType -eq 'Prov') -and (Version -eq 2)) -or ((ServiceType -eq 'Broker') -and (Version -eq 2)) -or ((ServiceType -eq 'Monitor') -and (Version -eq 1)) -or ((ServiceType -eq 'Sf') -and (Version -eq 1)) -or ((ServiceType -eq 'Trust') -and (Version -eq 1)) -or ((ServiceType -eq 'EnvTest') -and (Version -eq 1)) -or ((ServiceType -eq 'Analytics') -and (Version -eq 1)) -or ((ServiceType -eq 'Orch') -and (Version -eq 1))) -and (-not (ServiceAccountSid -in $sidsToExclude))} -InterfaceType "SDK" -MaxRecordCount 2147483647 | Test-ConfigServiceInstanceAvailability -AdminAddress "localhost" -BearerToken ******** -MaxDelaySeconds 5

Get-AcctServiceStatus  -AdminAddress "DDC_FQDN" -BearerToken ********
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,,
,,  
Get-SfServiceStatus  -AdminAddress "DDC_FQDN" -BearerToken ********


: The term 'Get-SfServiceStatus' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

+ CategoryInfo : ObjectNotFound: (Get-SfServiceStatus:String) [], ParentContainsErrorRecordException

+ FullyQualifiedErrorId : CommandNotFoundException

Get-SfServiceStatus  -AdminAddress "DDC_FQDN:80" -BearerToken ********

Error Source : Citrix Studio
StackTrace: Citrix.Orchestration.Base.LogicModels.Exceptions.ScriptException A working 'Storefront' service could not be found
at Citrix.Orchestration.Base.PowerShellSdk.HealthMonitor.Scripts.GetHealthyServiceInstanceScript.RunScript()

at Citrix.Orchestration.Base.PowerShellInteraction.PowerShellScript`1.Run()
at Citrix.Orchestration.Base.PowerShellSdk.HealthMonitor.Scripts.ReloadServiceInstance

Resolution

Install the storefront service ”Storefront_Service_X64.msi” from the CVAD ISO file and run that service.
If the Service is already present, then a repair will fix the issue.

Install missing prerequisite "Storefront_PowerShellSnapIn_x64

After running the MSI package, Studio opens without an error.


Problem Cause

The Storefront server was missing the PowerShellSnapin components.