WEM resets user-specified default printers in disconnected sessions

WEM resets user-specified default printers in disconnected sessions

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Article ID: CTX586970

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Updated On:

Description

  • Users manually select default printers in their WEM-enabled desktop sessions.
  • If they disconnect from the desktop (not log off), and an automatic WEM Agent refresh occurs post-disconnect, WEM resets the user-specified default printer for that session. Consequently, when the user reconnects to their session, they see that a random printer is selected as the default one instead. 
  • If a WEM refresh occurs within an active desktop session, the issue does not occur. 
  • If the 'Enable Automatic Refresh' setting in the WEM Administration Console (under 'Advanced Settings' > 'Advanced Options') is not selected or if there is no WEM Agent used in the session, the issue does not occur either.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

  1. On the VDA side, validate that the latest Microsoft patches are installed. Crucially, the September '22 updates must be in place.
  2. Create a the following registry key on the VDA under HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows:
Name: MaintainDefaultPrinter
Value Type: REG_DWORD
Data: 1

Problem Cause

A known issue on the Microsoft side:
  • By design, WEM Agent checks default printers during its auto-refresh.
  • To obtain the default printer value, WEM relies on a function from Microsoft. Earlier, Microsoft reported an issue in relation to that function where default network printers might be automatically changed.
  • To address that known issue, the VDA needs to be patched with the latest Microsoft updates and the aforementioned regkey must be created.

Additional Information

https://support.microsoft.com/en-us/topic/september-20-2022-kb5017379-os-build-17763-3469-preview-50a9b9e2-745d-49df-aaae-19190e10d307