book
Article ID: CTX586960
calendar_today
Updated On:
Description
SNMP configured for Power Supply but alerts not receiving
Resolution
The PSU OID - sysHealthPowerSupplyStatus is of the type ACCESSIBLE_FOR_NOTIFY. OIDs of this type
cannot be explicitly polled by an SNMP Manager (by performing SNMP GET, GETNEXT, etc.). They are sent in the form of varbinds only when NS generates a trap.
As documented in the
https://developer-docs.netscaler.com/en-us/adc-snmp-oid-reference/current-release.html, ; section of the OID Reference Guide, the PSU OIDs are used in the following traps –
powerSupplyFailed
OID:1.3.6.1.4.1.5951.1.1.0.82
This trap is sent when power supply has failed or disconnected from the system Varbinds sent in the trap message - sysHealthCounterName , sysHealthCounterValue , sysHealthPowerSupplyStatus , sysIpAddress To receive this trap enable snmp alarm POWER-SUPPLY-FAILURE
powerSupplyNormal
OID:1.3.6.1.4.1.5951.1.1.0.83
This trap is sent when power supply status returned back to normal Varbinds sent in the trap message - sysHealthCounterName , sysHealthCounterValue , sysHealthPowerSupplyStatus , sysIpAddress To receive this trap enable snmp alarm POWER-SUPPLY-FAILURE
https://support.citrix.com/article/CTX227493/netscaler-snmp-polling-and-trapsBut the Power supply status can be identified from the counters as per the below
https://support.citrix.com/article/CTX133887/citrix-adc-system-counters
Problem Cause
Power supply Unit SNMP alert via SNMP manager / snmp walk