Citrix WEM User Logon Service is causing logon delay
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Article ID: CTX586942
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Updated On:
Description
- End Users are reporting high logon times
- After the Logon breakup from Citrix Monitor page, most of the time is being taken during the Interactive Session Phase
- When looked at the Logon process from the Desktop side, delay is observed at "Please wait for the Citrix WEM User Logon Service" stage
- Behavior is only seen on the first Citrix Logon and not on the subsequent logons
Environment
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Resolution
- Make sure that the CC servers are not contacting any other DCs which are not reachable if its a multi-domain Cloud setup
- Engage Network/Hypervisor team to "disable "NetBios over TCP/IP" on each network adapter's TCP/IP v4 Properties, Advanced, WINS tab"
Problem Cause
The timeout occurs when the WEM agent collects user information for the CVAD Session Launch Event and it only occurs for the ICA session, which is not needed for the RDP session. So the problem only occurs in CVAD environment. It seems the Microsoft API
FindByIdentity may cause such delayed time which can be avoided by disabling NetBIOS over TCP/IP on all Hypervisor-Switch network interfaces. AD routing related issues can contribute to this additionally
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