Citrix Application Probe fails with "Enumeration Failed"

Citrix Application Probe fails with "Enumeration Failed"

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Article ID: CTX586626

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Updated On:

Description

ProbeAgent.txt on probe machine will show logging similar to the following:

  • 2023-12-11 11:00:21,068 [5] INFO - Starting probe job. DesktopId: Win10 Azure Desktop, Name: Win10 Desktop, Config Id: 1, Browser Name: Win10 Azure Desktop
  • 2023-12-11 11:00:21,068 [5] INFO - Running reachability check
  • 2023-12-11 11:00:21,088 [5] INFO - Reachability passed. Adding stage result
  • 2023-12-11 11:00:21,088 [5] INFO - Running authentication check. AuthType StoreFront
  • 2023-12-11 11:00:21,443 [5] INFO - Authentication passed. Adding stage result
  • 2023-12-11 11:00:21,443 [5] INFO - Running enumeration check
  • 2023-12-11 11:00:22,389 [5] INFO - Enumeration failed. Adding stage failure

The Name value in the example above is the PublishedName value of the resource.

Resolution

Update the PublishedName of the resource to match the BrowserName in the BrokerEntitlementPolicyRule.

The BrowserName cannot be edited.  If there is a need to change the BrowserName, one of the following must be done:

  1. Manually remove and replace the BrokerEntitlementPolicyRule via PowerShell
  2. Remove and rebuild the Desktop Group

Problem Cause

The BrowserName value is pulled from the BrokerEntitlementPolicyRule, which is associated to the Uid of the BrokerDesktopGoup.  If there is a mismatch between the BrowserName in the policy and the PublishedName of the resource (which is seen by the end user), this may cause an enumeration failure with Probe.

Issue/Introduction

Monitor probe may fail enumeration if the BrowserName value does not match the PublishedName of the resource.