Citrix App Layering - Error "Cannot convert undefined or null to object"

Citrix App Layering - Error "Cannot convert undefined or null to object"

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Article ID: CTX586319

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Updated On:

Description

Unable to import layers from a remote share. While attempting to connect to a share, we see the error  "Cannot convert undefined or null to object". The error message is displayed after about 10 mins. 

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Resolution

Removing the corrupted layer from the share resolved the problem.

Problem Cause

Possible corrupted layer

Additional Information

From MA Service log, we can see JSON read operations similar to the following:

08:27:12,379 INFO  [5555]  PortableRevisionDe: Reading Json from file /mnt/maserviceshare/mnt00000007/Exported Layers/W2016/Winzip/1.1.a21a6682c4d44c1584f7e18b9f36fd45.laypkg

This should be followed by the update that this query finished as seen below:

HandlerHelper: Finished Query PortableRevisionDetailsQuery->PortableRevisionDetailsResult

If we do not see this query finish, it is an indication that the corresponding layer is corrupt. (In this case 1.1.a21a6682c4d44c1584f7e18b9f36fd45.laypkg)

Removing that layer from the share should fix the problem.