Can't sign in to workspaces with SAML using custom domains

Can't sign in to workspaces with SAML using custom domains

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Article ID: CTX584994

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Updated On:

Description

Can't sign in to workspaces with SAML using custom domains, When try to access the custom domain URL get the error "Unable to Process Your Request, There was an unexpected error" .

Resolution

  1. Sign into Citrix Cloud at https://citrix.cloud.com.
  2. From the Citrix Cloud menu, select Workspace Configuration and then select Access.
  3. On the Access tab, under Custom Workspace URL,  select your custom domain and edit.
  4. Validate the Configuration SAML Connection to Citrix Cloud for Custom Domain. if the the SAML App URLs are not correct update as below.
  • In Identity Provider Entity ID for custom domain, enter the Entity ID from the second SAML application
  • In SSO service URL for custom domain, enter the SSO URL from the second SAML application.
  • In Logout URL for custom domain, enter the SLO URL from the second SAML application

Problem Cause

Custom domain configuration

Additional Information

https://docs.citrix.com/en-us/citrix-cloud/citrix-cloud-management/identity-access-management/saml-identity-custom-domain#dual-saml-application-configuration