The "Power Status" of all VDAs are displayed as "Unknown"

The "Power Status" of all VDAs are displayed as "Unknown"

book

Article ID: CTX584617

calendar_today

Updated On:

Description

In DaaS management, the "Power Status" of all VDAs was displayed as "Unknown", Power control (startup, shutdown, restart, etc.) could not be performed.

Also, when power control was executed, the log on the Citrix side would show "Success".  However, the power action was not executed on the Azure VDA side.

In addition, the machines in the delivery group do not start during the peak hours set in Autoscale either.

Environment

Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.

Resolution

Check if "Client secrets" is expired, if yes, then update the "Client secrets" with the below steps.
 
  1. Get the Application ID from the Full Configuration interface or using PowerShell.
  2. Sign in to the Azure portal.
  3. In Azure, select Azure Active Directory.
  4. From App registrations in Azure AD, select your application.
  5. Go to Certificates & secrets.
  6. Click Client secrets.


 

Problem Cause

When the expiration date of Client secrets expires, commands from the controller cannot reach Azure.

Additional Information

https://docs.citrix.com/en-us/citrix-daas/install-configure/connections/connection-azure-resource-manager.html#get-the-application-secret-in-azure
Get the application secret in Azure