Configuration logging display language not localized

Configuration logging display language not localized

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Article ID: CTX584588

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Updated On:

Description

The default language for the Web Studio configuration logging is English. To change the language, configure the Cloud-DDC locale instead of adjusting the language settings in the web browser.

Resolution

 

Change the configuration logging display language

  If you would like to change the display language of configuration logging, you can modify the locale information in DDC node.

You must run the shell or script using an identity that has Citrix administration rights.

  1. Set up the Remote PowerShell SDKs. See Manage Citrix DaaS using Remote PowerShell SDKs  for install procedures.
  2. Confirm the feature license is activated.
  3. Start a shell from the console. Click Studio, select the PowerShell tab, and click on Launch PowerShell.
  4. Execute C:\PS> Set-LogSite -Locale "zh-CN" to change your locale to zh-CN and make the logging function enable for the configuration change.

The locale parameter values can be 'en', 'ja', 'zh-CN', 'de', 'es' or 'fr'. 

After this operation, the configuration logging data will be logged using the set locale language.

After the Set-LogSite command is executed, you can leverage Get-LogSite to check in the same PowerShell window about the LogSite configuration you’ve set.  


Problem Cause

The requirement is initiated by cloud components utilizing a configuration stored in the cloud to specify the language for generating and storing logs. By default, this cloud configuration sets the logs to be created in English. It's crucial to note that the locale of the browser accessing Web Studio and the Citrix Cloud UI does not impact the language used in the generated logs.

To modify the language in which the logs are generated, a change to the cloud configuration is necessary. This adjustment allows for the logs to be generated in the desired language, diverging from the default English setting.