Unable to open license error recorded in Windows event log

Unable to open license error recorded in Windows event log

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Article ID: CTX584211

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Updated On:

Description

The Windows Event Log frequently shows an error that the license cannot be opened.
The following error appears when adding a Citrix license file (.lic) and checking the event log.

Source: Citrix_Licensing Event ID: 20754
Error: Unable to open license file. Please ensure that the file exists and is readable.

Resolution

1. Delete the old license file from the license server.

 License files are located in these directories and referenced by the license server

 32-bit server: C:\Program Files\Citrix\Licensing\MyFiles folder
 64-bit server: C:\Program Files(x86)\Citrix\Licensing\MyFiles folder

2. Reinstall the newly issued license file.

3. Restart all Citrix Licensing services on the license server.

Note:
  • Backup the original files before deleting them.

  • Confirm in the test environment before deleting.


Problem Cause

The license file may be corrupted.