User enumeration or launch failures after upgrading Citrix StoreFront to LTSR 2203 CU4

User enumeration or launch failures after upgrading Citrix StoreFront to LTSR 2203 CU4

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Article ID: CTX584143

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Updated On:

Description

After upgrading Citrix Storefront to 2203 Cu4, a high number of launch failures or enumeration may be reported by end users. 
 
Upon checking, you may notice that there is a high load on the CTX_Site database which is related to stored procedures being invoked.
As a result of this, it causes session launch and enumeration issues as the high load of requests are impacting users launching and enumerating their resources. 

Resolution

Citrix support has a fix created for this issue which is included in the new StoreFront 2203 LTSR, Cumulative Update 4 - Update 1 release. 

You can download the Storefront installer which has the fix here: https://www.citrix.com/downloads/storefront/product-software/storefront-2203-CU4-Update1.html 

If you still experience issues after installing Storefront with the fix, please contact Citrix Technical Support. 
 

Problem Cause

The issue is caused by increased NFuse requests(between StoreFront and DDC) for application enumeration data, which overwhelms DDC request processing capacity.

Additional Information

https://docs.citrix.com/en-us/storefront/2203-ltsr/whats-new/known-issues
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/2203-ltsr/known-issues