Citrix Studio 'session' field not showing username

Citrix Studio 'session' field not showing username

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Article ID: CTX584112

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Updated On:

Description

After upgrading, the Citrix Studio session view no longer shows the username, however, the username is displayed when checking the session from the Citrix Director.

Environment

The above mentioned sample code is provided to you as is with no representations, warranties or conditions of any kind. You may use, modify and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the sample code may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the sample code fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the sample code. In no event should the code be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SAMPLE CODE, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Although the copyright in the code belongs to Citrix, any distribution of the sample code should include only your own standard copyright attribution, and not that of Citrix. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the sample code.

Resolution

1. Rebuilding the WMI repository:
  1. Disable and stop the Winmgmt service.
  2. Remove or rename C:\Windows\System32\wbem\repository
  3. Enable and start the Winmgmt service.
  4. Open a CMD prompt as Administrator.
  5. In the CMD prompt Navigate to C:\Windows\System32\wbem\
  6. Run the cmd ‘for /f %s in ('dir /b *.mof') do mofcomp %s’ (this will take a minute or so to complete).
  7. Reboot machine.
2. Remove the VDA from the AD domain and rejoin it.
 

Problem Cause

It may be related to WMI data missing or loss of domain trust relationships.
 

Additional Information

VDAs will not register due to WMI Repository Corruption
https://support.citrix.com/article/CTX209830/vdas-will-not-register-due-to-wmi-repository-corruption