Error event ID 5002 recorded on StoreFront server

Error event ID 5002 recorded on StoreFront server

book

Article ID: CTX584016

calendar_today

Updated On:

Description

When starting Citrix Workspace, the User Name and Password inputs are not displayed. Restarting StoreFront temporarily resolves the issue.

The following error event log was recorded in the StoreFront Event Viewer.
Event ID 5002, Application Pool Citrix Delivery Services Authentication has been automatically disabled due to a series of errors in the process that provides services to the application pool.


 

Resolution

Applying antivirus exclusions on StoreFront Server.

StoreFront

Files:
%SystemRoot%\ServiceProfiles\NetworkService\AppData\Roaming\Citrix\SubscriptionsStore\**\PersistentDictionary.edb

Processes:
%ProgramFiles%\Citrix\Receiver StoreFront\Services\SubscriptionsStoreService\Citrix.DeliveryServices.SubscriptionsStore.ServiceHost.exe
%ProgramFiles%\Citrix\Receiver StoreFront\Services\CredentialWallet\Citrix.DeliveryServices.CredentialWallet.ServiceHost.exe

Note:

Please test in the environment first.

Problem Cause

StoreFront antivirus exclusions settings.
 

Additional Information


https://docs.citrix.com/en-us/tech-zone/build/tech-papers/antivirus-best-practices.html#storefront