'Use server time zone' setting not getting applied through Studio policy

'Use server time zone' setting not getting applied through Studio policy

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Article ID: CTX583921

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Description

PVS Target Device - Use server time zone policy is not getting applied on server 2019 VDA.
Citrix Policy "Use local time of client" is Configured. Value set to use time zone of user session (server time zone).
Registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services fEnableTimeZoneRedirection=1
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/policies/reference/ica-policy-settings/time-zone-control-policy-settings.html#use-local-time-of-client
CDF shows the policy value as 0.
CseEngine.exe,0,GroupPolicy_CoreLibrary,RegistrySetting.cpp,425,CRegistrySetting::SetValue,12,EntryExit,"CRegistrySetting::SetValue: path = Software\Policies\Citrix\3\User\UXPolicies name = UseLocalTimeOfClient value = <NULL> type = 4 operation = 0","
 

Resolution

Issue from Provisioning server end. Time zone on PVS server was not correct. Service( bndevice.exe) on target device pulls the server time zone.Updated the PVS server time and it reflect on target devices.
 

Problem Cause

Citrix 'BNdevice.exe' service is modifying 'TimeZoneInformation' registry key.  
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Note : TimeZoneInformation registry keys should not be altered manually. If values are not changed properly (including DST and others),this will end up with system in wrong time zone/ time settings. NLA might fail, one of the parameters to properly identify systems on network is system time.