Citrix Director Trends>Network page shows "Refused to connect" after integration with ADM

Citrix Director Trends>Network page shows "Refused to connect" after integration with ADM

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Article ID: CTX583883

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Updated On:

Description

"Refused to connect" message is seen on the Citrix  Director Trends>Network page after integrating with Citrix Application Delivery Management.


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Resolution

  1. On the ADM console, go to Settings
  2. Select System Administration > System Configurations  
  3. Click on Allowed URL’s and message of the day
  4. Select Allowed URLs List to add Director URL to frame-ancestors whitelist. 
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Problem Cause

ADM did not allow data to be retrieved by the Director URL in an iFrame.

HAR Logs show, Incomplete Response Received and Chrome Error  net::ERR_BLOCKED_BY_RESPONSE  when Director tries to reach the ADM server via call  GET https://adm.domain.com/admin_ui/mas/ent/html/dd.html
 

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The “ERR_BLOCKED_BY_RESPONSE” error message occurs when the client is blocked from receiving a response after sending a request for a resource hosted on the server.
 

Issue/Introduction

This article describes how to troubleshoot "Refused to connect" message on the Citrix  Director Trends>Network page after integrating with Citrix Application Delivery Management.

Additional Information