KeyNotFoundException message is shown in storefront event log
book
Article ID: CTX583729
calendar_today
Updated On:
Description
The exception message below is thrown out in the event log of storefront VM.
An unexpected error occurred retrieving the credentials.
System.Collections.Generic.KeyNotFoundException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=bcc12aa61934e089
The given key was not present in the dictionary.
at Citrix.DeliveryServices.CredentialWallet.InMemory.ConcurrentWallet.get_Item(Index index)
at Citrix.DeliveryServices.CredentialWallet.InMemory.InMemoryWallet.get_Item(Index index)
at Citrix.DeliveryServices.CredentialWallet.Service.CredentialWalletService.Retrieve(Byte[] index
Resolution
Log into storefront again to obtain the new token.
Problem Cause
This should be treated as by design.
This exception message usually happens after restarting Citrix Credential Wallet service.
After Citrix Credential Wallet service is restarted, the token cached in the service is lost, so if the client side uses the old token to communicate with storefront, exception will be output in event log.
Was this article helpful?
thumb_up
Yes
thumb_down
No