The taskbar is stop responding when launching a published desktop in Citrix Workspace app

The taskbar is stop responding when launching a published desktop in Citrix Workspace app

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Article ID: CTX583393

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Updated On:

Description

In a double-hop configuration, when launching a published application using Citrix Workspace App on the 1st-hop published desktop,
the taskbar might stop responding on the 1st-hop published desktop VDA.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

1) Start regedit as an administrator

2) Navigate to the following key
     For 32bit: HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICAClient\Engine\Configuration\Advanced\Modules
     For 64bit: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICAClient\Engine\Configuration\Advanced\Modules

3) Add a key with the following name directly under Modules
     GfxRender

4) Add the following value directly under GfxRender
     UseD3DHybrid (DOWRD) = 0

Note: Need to restart the PC when finished.

 

Problem Cause

Setting the registry will use DirectX 9 instead of DirectX 11.