Cloud : Load balancing and Autoscale does not work properly in citrix cloud

Cloud : Load balancing and Autoscale does not work properly in citrix cloud

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Article ID: CTX582203

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Updated On:

Description

Issues with Auto-scale and Load balancing on Cloud.
Autoscale is configured to shut down half of the servers during the weekend.
They have noticed there were once 138 sessions on Server until server crashed. Load balancing was not working as expected. Least loaded servers were not accepting session. 

 

Resolution

Not to use Natural reboot or set Idle timeout, as they could have long-lived sessions that keep the catalogs from being restarted and keep the catalog as not-preferred (NeedsStart). Or Configure Reboot schedule to Log Off user sessions,

Problem Cause

Scheduled Natural Reboot, machines are set to `NeedsStart` = True, which means that when the machine reaches 0 sessions, it will restart.

Additional Information

When using Scheduled Natural Reboot, machines are set to `NeedsStart` = True, which means that when the machine reaches 0 sessions, it will restart. In the meantime, machines that have NeedsStart = True will be less preferred. Less preferred machines will not be as fully loaded as those which are more preferred.