Error "Unable to launch your application" When Launching Published Applications
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Article ID: CTX582029
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Updated On:
Description
Error "Unable to launch your application. Contact your help desk with the following information: Cannot connect to the Citrix XenApp server. The Network is down" When Launching Published Applications Through Citrix Gateway.

Resolution
Reconfigure STA servers on NetScaler Gateway based on Storefront server settings:
- Navigate to NetScaler Gateway > Virtual Servers.
- In the details pane, select a virtual server and then click Edit.
- On the Published Applications tab, under Secure Ticket Authority, click Add.
- In the Configure STA Server dialog box, enter the URL of the STA server and then click Create.
- Repeat Step 4 to add additional STA servers and then click OK.
Check STA settings on the Storefront server:
- Select the Stores node in the left pane of the Citrix StoreFront management console and pane, click Manage Citrix Gateways.
- In the Manage Citrix Gateways window, slect a Citrix Gateway, click Edit.
- Click the Secure Ticketing Authority tab, then you can see all the Secure Ticket Authority URLs on the right pane.
Problem Cause
STA Server settings on NetScaler Gateway do not match the settings on Storefront server.
Issue/Introduction
Launching Published Applications failure through NetScaler Gateway with error: "Unable to launch your application. Contact your help desk with the following information: Cannot connect to the Citrix XenApp server. The Network is down"
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