Login using Okta shows the message "It doesn't look like you have any apps/desktops"

Login using Okta shows the message "It doesn't look like you have any apps/desktops"

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Article ID: CTX580516

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Updated On:

Description

When Okta authentication is used to login for Citrix Cloud, user don't see application or desktop.  Instead they get the message: "It doesn't look like you have any apps/desktops".

Environment

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Resolution

    Follow the below steps to disconnect and reconnect your Okta to Citrix Cloud using the new API created by Read-Only Administrator account.

    Disable Okta authentication for workspaces temporarily.

    1. Sign in to Citrix Cloud at https://citrix.cloud.com.
    2. From the Citrix Cloud menu, select Workspace Configuration > Authentication.
    3. Select Active Directory.
    4. When prompted, select I understand the impact on the subscriber experience.
    5. Select Save.

    Disconnect Citrix Cloud from your Okta organization

    1. From the Citrix Cloud menu, select Identity and Access Management.
    2. Locate Okta and select Disconnect from the ellipsis menu.
    3. When prompted, select Yes, disconnect  and wait for process to complete.

    Create an Okta API token

    1. Sign in to the Okta console using a Read-Only Administrator account.
    2. From the Okta console menu, select Security > API.
    3. Select the Tokens tab and then select Create Token.
    4. Enter a name for the token.
    5. Select Create Token.
    6. Copy the token value. You supply this value when you connect your Okta organization to Citrix Cloud.

    Connect Citrix Cloud to your Okta organization

    1. From the Citrix Cloud menu, select Identity and Access Management.
    2. Locate Okta and select Connect from the ellipsis menu.
    3. In Okta URL, enter your Okta domain.
    4. In Okta API Token, enter the API token for your Okta organization.
    5. In Client ID and Client Secret, enter the client ID and secret from the OIDC web app integration you created earlier. To copy these values from the Okta console, select Applications and locate your Okta application. Under Client Credentials, use the Copy to Clipboard button for each value.
    6. Click Test and Finish. Citrix Cloud verifies your Okta details and tests the connection.

    Enable Okta authentication for workspaces

    1. From the Citrix Cloud menu, select Workspace Configuration > Authentication.
    2. Select Okta.
    3. When prompted, select I understand the impact on the subscriber experience.
    4. Select Save.

    Problem Cause

    API tokens are generated with the permissions of the user that created the token. If a user’s permissions change, then so do the token’s. 

    Additional Information

    Refer to API token management for details on creating the Okta API tokens