Mac Workspace error "This store doesn't exist. Please retry or contact support"

Mac Workspace error "This store doesn't exist. Please retry or contact support"

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Article ID: CTX579572

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Updated On:

Description

After plugging-in Gateway URL on Mac Workspace and entering credentials, Workspace prompt error "This store doesn't exist. Please retry or contact support".

Environment

This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.

Resolution

To configure correct expression in session policy that supports Mac Workspace, for example:
 
  1. Go to Citrix Gateway > Policies > Session > Session Policies.
  2. Select and edit existing session policy for Mac Workspace.
  3. In Expression field, replace with following information and click OK.

HTTP.REQ.HEADER("User-Agent").SET_TEXT_MODE(IGNORECASE).CONTAINS("macos")&&HTTP.REQ.HEADER("User-Agent").CONTAINS("CitrixReceiver")

Problem Cause

Fail to hit existing session policy after authenticating to Gateway.

The configured session policy expression for Mac Workspace contains "HTTP.REQ.HEADER(\"User-Agent\").CONTAINS(\"Macintosh\")", but the User-Agent actually is "macOS" that can be found in POST request URL "/nf/auth/webview/done" according to nstrace taken on NetScaler.

POST /nf/auth/webview/done HTTP/1.1
Host: xxx.com
Accept: application/vnd.citrix.authenticateresponse-1+xml, application/vnd.citrix.gatewaysession-1+xml
X-Citrix-AM-LabelTypes: confirmation,error,heading,information,none,plain,warning
X-Citrix-AM-CredentialTypes: domain,newpassword,none,passcode,password,pin,realm,rsa-next-passcode,rsa-next-tokencode,rsa-passcode,rsa-pin,savecredentials,textcredential,username,webview
X-Citrix-Gateway: xxx.com
Accept-Language: en
Accept-Encoding: gzip, deflate, br
Content-Type: application/x-www-form-urlencoded
Content-Length: 63
User-Agent: CitrixReceiver/23.07.0.64 macOS/13.5.1 AuthManager/23.07.0 X1Class CWACapable CWA/23.07.0.64
Connection: keep-alive
Cookie: NSC_TASS=/No%20Page


If no session policy is hit, the Global Citrix Gateway Settings (GUI: Citrix Gateway > Global Settings > Change Global Settings) is applied. By default, ICA Proxy is OFF and Plug-in is set to Java. With this settings, Workspace fails to discovery store and log off, users will encounter error "This store doesn't exist. Please retry or contact support".

Issue/Introduction

Cannot add account on Mac Workspace with error "This store doesn't exist. Please retry or contact support" because no session policy is hit.

Additional Information

https://docs.netscaler.com/en-us/citrix-gateway/current-release/vpn-user-config/configure-gateway-session-policies-for-storefront.html

https://docs.netscaler.com/en-us/citrix-gateway/current-release/storefront-integration/ng-clg-session-policies-overview-con.html ​​​​​​​