Fail to launch session with Event ID6 error after changing display setting.

Fail to launch session with Event ID6 error after changing display setting.

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Article ID: CTX579139

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Updated On:

Description

 

Launch session takes 6~7 seconds and then fails. Check the Event Log, there are several Event ID 6 Errors recorded.

Error Message:

Citrix ICA could not configure Thinwire and switch to the remote ICA display. Rebooting the workstation or logging in to the console will fix this.

Environment

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Resolution

Delete below registry key on VDA Machine and reboot VDA :

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\MonitorDataStore] 
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Problem Cause

 

Change Advanced display can lead to the registry value of "MonitorDataStore" being changed. This cause graphic problem. 

ICA session cannot launch successfully due to a graphic problem. 




 

Additional Information

 

Other Displays related can also occur with the same issue.

Examples like VMware Tools update will change Thinwire graphics driver occasionally, this also can cause this issue.

 

Unable to Connect to XenDesktop Virtual Desktop Agent on Windows 7 with VMware Tools ESX 4.0 Update 1

https://support.citrix.com/article/CTX123952

 

In this scenario, change the "Remove display from desktop" setting from "Advanced display settings". The issue occurs after this change.