HTML5 external users are not able to launch applications via Netscaler Gateway, Workspace works.
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Article ID: CTX575082
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Updated On:
Description
Users connecting externally are not able to launch connections with the Light (HTML5) browser access but are able to launch with the Workspace App.
Error displayed: "Citrix Workspace app cannot connect to the server. Please check your network connection or contact your help desk for assistance."
Network trace did not show any WebSocket connection received by the Gateway.
Resolution
Allow WebSocket connections over port 443 to the Gateway that HTML5 users are connecting to.
Problem Cause
Gateway virtual server had been migrated from a different device and the IP changed. The firewall rule in place for the new Gateway IP, did not allow for incoming WebSocket connections on port 443.
Issue/Introduction
When using HTML5 Workspace (receiver) ensure that incoming WebSocket connections are allowed on port 443 for the Gateway.
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