Session launch takes a long time and a login dialog displays in Desktop Viewer window

Session launch takes a long time and a login dialog displays in Desktop Viewer window

book

Article ID: CTX574749

calendar_today

Updated On:

Description

More than 20 seconds later login dialog appears in Desktop Viewer window during session launch operation.
Launch session takes a long time, then login dialog appears. Session can be launched if provide proper certificate to login.
This issue often occurs on first launch session operation, rarely seen this behavior at reconnect session.

Environment

Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.

Resolution

Remove unexpected and duplicate DNS records on DNS Server. (something like following screenshot)
We can remove DNS Record from DNS Server=>DNS Manager=>Select a DNS record which you want to delete=>Click Delete to remove the DNS record.

image.png
 

Problem Cause

DDC has completed Validation Request in a short time, but VDA has much delay when try to process the Validate Response from DDC.
Massive DNS Records lead to VDA validate response process take a long time.
As a result, session not launched as expected .