“The Access Policy has externally been modified and cannot be changed by Studio” warning message

“The Access Policy has externally been modified and cannot be changed by Studio” warning message

book

Article ID: CTX573847

calendar_today

Updated On:

Description

After setting access policy rule, “Access Policy” option in “Edit Delivery Group” dialog cannot display.

------------------------
Add-PSSnapin -Name Citrix.*
Set-BrokerAccessPolicyRule '<DeliveryGroupName>_AG' -IncludedClientIPFilterEnabled $True
Set-BrokerAccessPolicyRule '<DeliveryGroupName>_AG' -IncludedClientIPs xxx.xxx.xxx.xxx
Set-BrokerAccessPolicyRule '<DeliveryGroupName>_Direct' -IncludedClientIPFilterEnabled $True
Set-BrokerAccessPolicyRule '<DeliveryGroupName>_Direct' -IncludedClientIPs xxx.xxx.xxx.xxx

------------------------
Note: <DeliveryGroupName> is the variable that represents the actual delivery group name.

“Access Policy” option shows the warning message as below.
image.png
 

Resolution

This is expected behavior by design.

 

Problem Cause

  • Some kinds of access policy rules (IncludedClientIPFilterEnabled , etc) can only be edited by command line, GUI does not have the corresponding setting options.
  • To avoid conflicts, GUI editing will not be allowed after executing command to update these kinds of access policy rules.