“The Access Policy has externally been modified and cannot be changed by Studio” warning message
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Article ID: CTX573847
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Updated On:
Description
After setting access policy rule, “Access Policy” option in “Edit Delivery Group” dialog cannot display.
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Add-PSSnapin -Name Citrix.*
Set-BrokerAccessPolicyRule '<DeliveryGroupName>_AG' -IncludedClientIPFilterEnabled $True
Set-BrokerAccessPolicyRule '<DeliveryGroupName>_AG' -IncludedClientIPs xxx.xxx.xxx.xxx
Set-BrokerAccessPolicyRule '<DeliveryGroupName>_Direct' -IncludedClientIPFilterEnabled $True
Set-BrokerAccessPolicyRule '<DeliveryGroupName>_Direct' -IncludedClientIPs xxx.xxx.xxx.xxx
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Note: <DeliveryGroupName> is the variable that represents the actual delivery group name.
“Access Policy” option shows the warning message as below.
Resolution
This is expected behavior by design.
Problem Cause
- Some kinds of access policy rules (IncludedClientIPFilterEnabled , etc) can only be edited by command line, GUI does not have the corresponding setting options.
- To avoid conflicts, GUI editing will not be allowed after executing command to update these kinds of access policy rules.
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