Workspace App toolbar "Devices" option is missing on specific Windows clients

Workspace App toolbar "Devices" option is missing on specific Windows clients

book

Article ID: CTX571269

calendar_today

Updated On:

Description

Regarding to same user and VDA, Citrix Workspace App (CWA) toolbar "Devices" option can show normally on some Windows clients. But on specific Windows clients, "devices" option is missing.

Resolution

Re-install Citrix Workspace App with administrator privileges.

Problem Cause

  • If CWA is installed by administrator privileges, then USB module folder "Drivers64" will be created under C:\Program Files (x86)\Citrix\ICA Client\
  • For domain users without administrator privileges, no USB module created under %USERPROFILE%\AppData\Local\Citrix\ICA Client\
CWA is installed by domain user without administrator privileges, then USB module will not be installed. 
 

Additional Information

https://docs.citrix.com/en-us/citrix-workspace-app-for-windows/install