License and ciphers are missing after upgrading to the latest version on 13.0 and 13.1 

License and ciphers are missing after upgrading to the latest version on 13.0 and 13.1 

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Article ID: CTX571141

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Updated On:

Description

License and ciphers are missing after upgrade to the latest version on 13.0 and 13.1 

Resolution

  • Access to ADC GUI was lost. It might go into freemium mode too while upgrade
  • Found out in trace that ADC was sending reset code (code:9811) while accessing GUI from client machine
  • From reference article - https://support.citrix.com/article/CTX200852/citrix-adc-netscaler-reset-codes-reference - issue was related to cipher mismatch  
  • Upon checking license , found that license was lost –

            Command: Show ns license
 
  • License was invalid, hence some of the  ADCs  features and configuration was lost.
  • Upon further investigation found that  default ssl profile was bound to internal service nshttps-127.0.0.1-443 but cipher binding was missing on default profile 
  • Command: show service -internal , look for nshttps-127.0.0.1-443

             Note down cipher/ssl profile bound to it.
 
  • Opened SSL profile ns_default_ssl_profile_frontend. Command: show ssl profile ns_default_ssl_profile_frontend
  • Looked for default cipher and it was missing too.
 
Show cipher default 

image.png
 
  • Hence SSL handshake was failed 
  • Try to access on Http if HTTP is  allowed in environment


Please make sure your license is correct on ADC.
If you are using local license then, subscription advantage date should be update in you .lic file, which is present under nsconfig/license folder.
If you are using ADM or license server, make sure you have proper connectivity before upgrading.

While upgrading you will get the below message:

image.png

Please look into it before upgrading.

Problem Cause

ADC lost its ciphers post upgrade and lost the capability to connect on GUI

Issue/Introduction

1> License lost 2> Hence features were lost and some of the config was lost too. 3> Fixing license fixed the issue.

Additional Information

https://support.citrix.com/article/CTX200852/citrix-adc-netscaler-reset-codes-reference