Endpoint IP shows as "127.0.0.1" in Director

Endpoint IP shows as "127.0.0.1" in Director

book

Article ID: CTX571056

calendar_today

Updated On:

Description

Endpoint IP column doesn't show the true Client IP address. 
Instead, it shows as "127.0.0.1" in Citrix Director (or Citrix Cloud Monitor).

Error image.JPG

 

Resolution

Resolution 1:
This is expected behavior if the session was launched via RDP/Console Connection.


Resolution 2:
If the session was launched via Citrix ICA Connection and Client proxy was configured, disable the Client proxy to determine if issue resolved by reflecting the true client IP address.

Problem Cause

Cause 1:
The session was launched via RDP/Console Connection. Not via Citrix ICA Connection.


Cause 2:
Client proxy has modified the client IP address as 127.0.0.1.