Azure MCS catalog update fails with FailedToStartImagePreparationVm - CreateUpdateVm-1 timed out

Azure MCS catalog update fails with FailedToStartImagePreparationVm - CreateUpdateVm-1 timed out

book

Article ID: CTX568023

calendar_today

Updated On:

Description

Unable to update a machine catalog for an Azure hosted MCS deployment.
The MCS process fails early (about 15% into the update)

The error message shows "Error - Terminated", and the action name is "MC_UpdateMachineCatalog"
The full stack trace is similar to this :
 

Terminated
Stack Trace:
    at Citrix.Orchestration.Base.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeTask.ThrowOnTerminatingError(SdkProvisioningSchemeAction sdkProvisioningSchemeAction)
    at Citrix.Orchestration.Base.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeTask.WaitForProvisioningSchemeActionCompletion(Guid taskId, Action`1 actionResultsObtained)
    at Citrix.Orchestration.Base.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.PublishProvisioningSchemeImageTask.RunTask()
    at Citrix.Orchestration.Base.PowerShellSdk.BackgroundTaskService.BackgroundTask.Task.Run()

DesktopStudio_ErrorId : ProvisioningTaskError
ErrorCategory : NotSpecified
ErrorID : FailedToStartImagePreparationVm
TaskErrorInformation : Terminated
InternalErrorMessage : Error starting machine. CreateUpdateVm-1 timed out while retrying operation

 

Environment

Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.

Resolution

A timeout of the CreateUpdateVm-1 task can be caused by a full Azure Cores quota.
If there are not enough cores available in the tenant, the MCS preparation VM cannot be created, and the catalog update will fail.

You should verify the quota set for cores on your Azure subscription. If this quota is full or almost full, there are two options
  • Extend your cores quota to have enough available cores.
  • Shut down some unused machines in your environment to free up cores.
You may refer https://learn.microsoft.com/en-us/azure/quotas/view-quotas for the Azure quota settings. 

Problem Cause

Limited resources as per the defined Azure Quota

Issue/Introduction

Update MCS fails because the Azure cores quota was met