Shortcuts to apps not seen in the start menu of the published desktop

Shortcuts to apps not seen in the start menu of the published desktop

book

Article ID: CTX566604

calendar_today

Updated On:

Description

Shortcuts are not visible in the published desktop or windows start menu even after the correct policies have been applied (Enable Desktop shortcut).

Resolution

Disable user subscriptions (Mandatory Store) on Storefront on prem solved the issue:

image.png

Problem Cause

This is by design. When a store uses the default of having User Subscriptions self-service mode enabled, only user-subscribed & mandatory application and desktop shortcuts are placed on the start menu and/or desktop. When a store has User Subcriptions disabled, all published application and desktop shortcuts are placed on the client start menu or desktop. This also requires shortcut creation to be enabled in Citrix Workspace App.

Issue/Introduction

Users couldn't see the application shortcut on the published desktop because the user subscription was enable

Additional Information

https://docs.citrix.com/en-us/storefront/1912-ltsr/configure-user-access.html#configure-user-subscriptions