Error: "The connection to "xxx" failed with status (Unknown client error 1110). SSL Error 31"

Error: "The connection to "xxx" failed with status (Unknown client error 1110). SSL Error 31"

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Article ID: CTX564355

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Updated On:

Description

When accessing Applications via Citrix Gateway, the Applications' ICA file download successfully, but launching failed with below errors:

"Unable to connect to the server. Contact your system administrator with following error: SSL Error 31: The operation completed successfully"
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Error 'The connection to "xxx" failed with status (Unknown client error 1110)' prompt at the same time.
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Resolution

Allow Citrix Workspace ICA session traffic to NetScaler on the Third party Firewall.

Problem Cause

ICA session traffic is wrapped with TLS protocol and using 443 port. 
The third party Firewalls may try to parse ICA session traffic referring HTTPS protocol but failed, which result firewall block ICA session traffic from Citrix Workspace to NetScaler Gateway.

For Windows Workspace Launched ICS session traffic, the Client Hello's Server Name field is filled in uppercase format. e.g: DESKTOP.LAB.TEST
You may tracing packets in Wireshark like below: the No.23513 packets is the ICA session traffic's client hello message.

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