Blank Windows Display when Open Citrix Workspace APP

Blank Windows Display when Open Citrix Workspace APP

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Article ID: CTX564276

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Updated On:

Description

When opening Citrix Workspace App, it displays blank. User cannot input store's URL or username&password to login. However, the ICA session can be launched through browser.

It shows msedgewebview2.exe crashed because tsafedoc64.dll does not meet the Microsoft signing level requirement in Event Viewer.
The event log can be found under CodeIntegrity Event Log:

  1. Click Start, point to Administrative Tools, and then click Event Viewer.
  2. Expand Applications and Service Logs, expand Microsoft, expand Windows, expand CodeIntegrity, and then click Operational.image.png

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Disable Edge RendererCodeIntegrity feature on the issued client:
  1. Open Registry Editor dialog
  2. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge
  3. Create a new DWORD key with the name "RendererCodeIntegrityEnabled" and value 0
  4. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge\WebView2
  5. Create a new DWORD key with the name "RendererCodeIntegrityEnabled" and value 0

Problem Cause

Third party tsafedoc64.dll does not meet the Microsoft signing level requirement, cause Edge WebView2 process failed, which lead the workspace display abnormally.

Issue/Introduction

Third party tsafedoc64.dll does not meet the Microsoft signing level requirement, cause Edge WebView2 process failed, which lead the workspace display abnormally.