Virtual Desktop:Remote PC physical console black screen

Virtual Desktop:Remote PC physical console black screen

book

Article ID: CTX563465

calendar_today

Updated On:

Description

Disconnect RemotePC ICA session, black screen and unresponsive when trying to log in physically.
User has to reboot PC to work normally.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Add the following registry on the remote pc  to mark the current VDA as a physical machine.

HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\PortICA
Name: ForceEnableRemotePC
Type: DWORD
Data: 1

Problem Cause

Because the OS virtualization based security features, vda software cannot correctly detect the machine as a physical.

Additional Information

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/install-configure/remote-pc-access.html