ICA latency in Director frequently displays high (not 64000ms) when accessed via NetScaler Gateway
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Article ID: CTX561489
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Updated On:
Description
When user accessed Virtual Desktop via NetScaler, admin may find the "ICA latency" in Director frequently displays unreasonable high value(not 64000ms), while "ICA RTT" value is in normal range. It's telling ICA RTT >ICA latency.
In fact, users have no high latency or bad interaction experience while using Virtual Desktop.
Environment
This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.
Resolution
From NetScaler release 13.0 build 83.17+,13.1 build 11.2+, you can specify a time interval, in seconds, for which the L7 client latency value is to be calculated in NetScaler.
Apply the following command in NetScaler as a workaround:
>set ica parameter -L7LatencyFrequency 5.
- For NetScaler release before 13.0 build 83.17,13.1 build 11.2, please schedule to upgrade your NetScaler to the fixed version with priority. While you may disable NetScaler L7 client latency calculation as a temporary workaround by applying below shell command:
#nsapimgr -ys enable_ica_l7_latency=0
(Run "save c" in the ADC prompt after running the above command to reflect the changes).
Problem Cause
It's a false positive alarm regarding user's poor experience. The incorrect ICA Latency value is miscalculated while involving NetScaler's L7 client latency value.
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