VMs fail to boot with error: "SR_BACKEND_FAILURE_46, The VDI is not available"

VMs fail to boot with error: "SR_BACKEND_FAILURE_46, The VDI is not available"

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Article ID: CTX559575

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Updated On:

Description

VMs fail to boot with error: SR_BACKEND_FAILURE_46 [ ; The VDI is not available [opterr=['INTERNAL_ERROR', '(Sys_error\\n  "/var/run/nonpersistent/forkexecd/execute_command_get_errc83846.log: Too many open files")']];  ]

Environment

This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.

Resolution

  1. Locate the target host where these problematic VMs from;
  2. Check opening files under root /:
find / -xdev -printf '%h\n' | sort | uniq -c | sort -k 1 -n -r |more
  1. Free up space under /var/xapi/blobs/:
# xe message-list --minimal | tr , '\n' | while read f; do xe message-destroy uuid=$f; done

 

Problem Cause

VMs were shutdown failed from one host which has opened more than 10000 files under  /var/xapi/blobs/ directory, so VDIs are still locked on the host: