ONPREM|CVAD 2203CU2| Citrix Studio policies are not getting applied to random VDAs
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Article ID: CTX557768
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Updated On:
Description
- All of the Citrix policies configured in the Citrix Studio are not applied on a few VDAs
- Other VDAs in the same Delivery group have all policies applied correctly
- You might observe the below on the affected VDAs,
- No error or warning message in event log related to CseEngine or Group Policy
- Folder "C:\ProgramData\CitrixCseCache" is empty
- Folder "C:\ProgramData\Citrix\GroupPolicy" contains multiple subfolders(numbered)
- Registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix" contains multiple subkeys (numbered, same as numbered subfolders in ..\Citrix\GroupPolicy" folder)
- Registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICAPolicies" is empty
- Registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\LoadManagement" is empty
- Registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\VCPolicies" is empty
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
- Delete the content of the folder “C:\ProgramData\Citrix\GroupPolicy”
- Delete the entries on the registry HKLM\Software\Policies\Citrix and the “HKLM\Software\WOW6432Node\Policies\Citrix\” key (only session folders)
- Restart Citrix CSE service and Broker Agent service on affected VDAs
Problem Cause
This is observed when the session keys under the path HKLM\Software\Policies\Citrix and the HKLM\Software\WOW6432Node\Policies\Citrix are not deleted on logoff or reboot of Manual VDAs. This is applicable only to random MCS/PVS VDAs.
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