[NS 13.1]iOS/Android Workspace adding account failure via NetScaler Gateway

[NS 13.1]iOS/Android Workspace adding account failure via NetScaler Gateway

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Article ID: CTX554245

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Updated On:

Description

After NetScaler upgrade from 13.0 to 13.1, end-user may find Mobile Workspace Application will prompt error when adding account via NetScaler Gateway:
On Android Workspace: it shows
"An error has occurred while connecting. Check your server address and data connection. Error Code 548."
On iOS Workspace,  it shows
"Could not verify server address"

Environment

This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.

Resolution

Please apply below command in NetScaler CLI as a workaround to fix this issue.
bind policy patset ns_vpn_client_useragents AGEE -index 1 -charset ASCII
bind policy patset ns_vpn_client_useragents CitrixReceiver -index 2 -charset ASCII
bind policy patset ns_vpn_client_useragents AGMacClient -index 3 -charset ASCII
bind policy patset ns_vpn_client_useragents "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0" -index 4 -charset ASCII
bind policy patset ns_vpn_client_useragents "Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0" -index 5 -charset ASCII
Citrix will apply issue fix in NetScaler's coming release, you may contact Citrix Support for more detailed release info.

Problem Cause

This is a Known issue(NSHELP-33451) in NS 13.1 that part of  build-in Pattern Sets settings is missing in some build.

  • You may confirm this issue via below command running in NetScaler CLI: 

> show policy patset ns_vpn_client_useragents
        Default Patset: ns_vpn_client_useragents
        Description: ???
 Done
>

 

  • For working NetScaler environment, upper command output will be :

> show policy patset ns_vpn_client_useragents
        Default Patset: ns_vpn_client_useragents
        Description: ???

1)      Bound Pattern:  AGEE    Index:  1       Charset:        ASCII
2)      Bound Pattern:  CitrixReceiver  Index:  2       Charset:        ASCII
3)      Bound Pattern:  AGMacClient     Index:  3       Charset:        ASCII
4)      Bound Pattern:  Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0    Index:  4       Charset:        ASCII
5)      Bound Pattern:  Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0      Index:  5       Charset:        ASCII
 Done
>