CVAD 2303 Users stuck on welcome screen when reconnecting to a disconnected session

CVAD 2303 Users stuck on welcome screen when reconnecting to a disconnected session

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Article ID: CTX547782

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Updated On:

Description

Users attempting to reconnect to a disconnected sessions on CVAD 2303 VDA, will get stuck on Welcome screen.
The session shows "Active" from Studio Console as well as in Task Manager Users tab on the server.

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Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Hotfix package name: HDX49992.zip
For: Computers running Virtual Delivery Agent 2303 for Windows Desktop OS or Windows Server OS with the ACR enabled
Date: May, 2023

Hotfix install and uninstall instructions 

Single-session VDA install:

  1. Connect to the VDA using rdp/console

  2. Rename the existing binary CtxGfx.exe & GfxMgr.exe available at "C:\Program Files\Citrix\HDX\bin" (Ex: CtxGfx_old.exe)

  3. Copy the safe private files in the WS folder (CtxGfx.exe + GfxMgr.exe) to "C:\Program Files\Citrix\HDX\bin"

  4. Restart the VDA.

Multi-Session VDA install:

  1. Connect to the VDA  using rdp/console

  2. Rename the existing binary i.e., CtxGfx.exe & IcaGfxStack.dll available at "C:\Program Files\Citrix\HDX\bin"  (Ex: CtxGfx_old.exe)

  3. Copy the safe private files  to "C:\Program Files\Citrix\HDX\bin" from the TSVDA folder (CtxGfx.exe + IcaGfxStack.dll) to "C:\Program Files\Citrix\HDX\bin"

  4. Restart the VDA.

To uninstall this hotfix:

  1. Connect to the VDA  using rdp/console

  2. Delete the Safe Private i.e.,CtxGfx.exe & IcaGfxStack.dll available at "C:\Program Files\Citrix\HDX\bin" in TSVDA and CtxGfx.exe & GfxMgr.exe "C:\Program Files\Citrix\HDX\bin" in WSVDA.

  3. Rename the original binary (Ex: CtxGfx_old.exe) available at "C:\Program Files\Citrix\HDX\bin" in TSVDA and WSVDA.

  4. Restart the VDA.


Problem Cause

A change was introduced in 2303 that affects how we are loading our graphics virtual channel exposing this issue

Additional Information

Citrix Discussion: https://discussions.citrix.com/topic/418468-xenapp-vda-2303-reconnecting-to-disconnected-session-problems/page/3/