Auto-Created Printers not Deleted after Users Log Off

Auto-Created Printers not Deleted after Users Log Off

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Article ID: CTX51476

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Updated On:

Description

Auto-created printers fail to delete after logging off.

When a network or locally attached Citrix client-defined printer is auto-created as a client printer, the comment field is defined as such. Citrix uses this field to determine if this printer object must be deleted at log off.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

To resolve the issue, verify the locations and versions of both ctxnotif.dll and cpmon.dll:

Ctxnotif.dll should be located on the XenApp server location:
C:\Program Files (x86)\Citrix\System32

XenApp servers REGEDIT location:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\MetaFrame

Value name: DLLName

Type: REG_SZ

Value data: ctxnotif.dll
 

Cpmon.dll on the XenApp server location:

C:\Program Files (x86)\Citrix\System32


XenApp servers registry under:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Client Printer port

Value Name: Driver

Type: REG_SZ

Value data: cpmon.dll


    Problem Cause

    The following list provides the possible causes for the issue to occur:

    • The object was manually created. Therefore, there is no comment field.

    • The comment field was altered. This might have been done to make the printer “static” or for other troubleshooting or application purposes.

    • The session is in a disconnected state and/or the users profile has not unloaded successfully. The Disconnected scenario is by design. There are other Microsoft TechNet articles and possible Citrix Knowledge Center articles to help troubleshoot the second scenario.

    • Print Jobs were pending in the print queue. They were not set to delete at log off and/or users could not delete pending jobs before logoff. Following are more details.

    • The spooler service might not be working or was not working properly upon log off. This might require the manual deletion of printer objects from the registry of the server, HKLM\System\CurrentControlSet\Control\Print\Printers, and the restarting of the print spooler service. Also see CTX112580 – Case Study: Intermittent Client Printer Creation and Deletion Failures.

    • Auto-created printers created using the legacy naming style might not be deleted when a session is terminated. The issue occurs if the Print Spooler and Citrix Print Manager Service restart while a session is active on the server.

    • Auto-created printers that no longer have an associated session are not deleted when the Citrix Print Service (CPSVC) restarts.

    • Under certain circumstances, session printers are not deleted when a user session is reset.

    • Non auto-created printers attached to client devices are incorrectly deleted when the spooler service is restarted.

    Issue/Introduction

    This article contains information on auto-created printers that are not deleted after users log off.