Intermittent Enumeration of Resources [Azure AD]
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Article ID: CTX495517
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Description
Intermittent Enumeration of Resources [Azure AD] : Some apps and desktops enumerations are missing at the user's Store, and appear back intermittently after reauthenticating to the Store.
Resolution
- The Security Groups have to be configured with Universal Scope in the Active Directory instead of Global.
- Adding a group as a member of another group (nesting) is supported with the
DSAuthAzureAdNestedGroups
feature enabled. You can enable DSAuthAzureAdNestedGroups
by submitting a request to Citrix Support. - In some cases, the issue happens due to an outdated Cloud Connector, which can be resolved by
- Removing the Cloud Connectors from the Resource Location, one by one.
- Uninstalling the installed version, and reinstalling the latest version available.
- Restarting the Cloud Connectors, one by one.
Problem Cause
Problem with the Scope of the Security Groups of the users whose enumeration fail intermittently.
Issue/Introduction
The Security Groups have to be configured with Universal Scope in the Active Directory instead of Global.
Additional Information
https://docs.citrix.com/en-us/citrix-workspace/secure.html#azure-active-directory
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